[nas] Re: Configuring NAS and libaudiooss

Janyne Kizer janyne_kizer at ncsu.edu
Wed Jan 23 14:42:53 MST 2002

Thanks a lot.  For testing I added /usr/X11R6/bin to the LD_LIBRARY_PATH
(figuring that if it worked I'd update the necessary files and if it
didn't, oh well).  That did help but nasd is still not loading.

This is what I did:
export LD_LIBRARY_PATH=/usr/X11R6/lib/
export AUDIOSERVER=myxtermipaddress:0.0
export LD_PRELOAD=/usr/X11R6/libaudiooss.so.1.0

audemo works now (no more libaudio.so.2 error), however other sound
making programs do not.  

When I start nasd I am continuting to get this.  I am looking into this
problem but any suggestions would be appreciated.

Jan 23 16:31:22 linus modprobe: modprobe: Can't locate module
Jan 23 16:31:22 linus modprobe: modprobe: Can't locate module

Tobias Diedrich wrote:
> Janyne Kizer wrote:
> > Right.  I could get sound on the HMX with just NAS installed.  I
> > installed libaudiooss in an attempt to get sound from other applications
> > like flash.  I was testing with midi synth and a few other sound making
> > applications.  This works whether or not I've done "export
> > AUDIOSERVER=myterm:0.0" and always fails after "export
> > LD_PRELOAD=/user/X11R6/lib/libaudiooss.so.1.0."  The error is "error
> > while loading shared libraries:  libaudio.so.2: cannot open shared
> > object file:  No such file or directory."  I have checked and
> > libaudio.so.2 does exist in /usr/X11R6/lib.  This was not in my path.  I
> > added it to my path and I continue to get this error after "export
> The linker can't find libaudio...
> Interesting if it works fine with auplay.
> What is the output of "ldd `which auplay`" and
> "ldd /usr/X11R6/lib/libaudiooss.so.1.0" ?
> libaudio should be in a directory that is in the dynamic linkers path
> (which is different from your $PATH), otherwise you have to either set
> LD_LIBRARY_PATH (which is discouraged IIRC) or change the makefile...
> (i.e /usr/local/lib is usually not in the linkers path)
> --
> Tobias Diedrich                                                 PGP: 0x9AC7E0BC
> Systemadministration IfI-A


Janyne Kizer
CNE-3, CNE-4, CNE-5
Systems Programmer Administrator I
NC State University, College of Agriculture & Life Sciences
Extension and Administrative Technology Services
Phone: (919) 515-3609

More information about the Nas mailing list