[nas] No love (could not create audio connection block info when starting)

Paul England pengland at cmtkg.com
Mon Sep 13 01:18:04 MDT 2004

Thanks for the reply Jon.
I dug around a bit, and I think I've fixed it (won't know until the morning)

I had to shutdown the machine in a rather nasty way today.  I think this 
the root of the problem.  I looked in /tmp/.sockets, and saw that audio0 
audio5000+ was taken (probably what happened when I ran my perl script
to find an open port) :(.

Anyways, I deleted all of these and restarted.  I'm thinking I've got 
the problem
fixed.  nasd starts, and my Qt app thinks that NASD is available, so 
that's definitely
better than before.

I'll come back wining in the morning if it doesn't though.


> On Mon, 13 Sep 2004, Paul England wrote:
>> I get the following error
>> Fatal server error:
>> could not create audio connection block info
>> when running:
>> nasd :x -aa &
>> where x = 1 thru 65000 or so (I wrote a script to try them all).
>> This is strange, as I know not all network ports are in use.
>> Any help is appreciated
>     What version of nas are you running?  If you are using a newer 
> version (1.6d or better) try running nas with '-v -d 99' and see if 
> you get better information (maybe in your syslog file).
>     This error usually means that it could not access the audio 
> hardware for some reason...

More information about the Nas mailing list