[nas] cc/gcc issues with imake on Solaris 8

Nick Ing-Simmons nick at ing-simmons.net
Thu Apr 15 05:48:10 MDT 2004

<rhfreeman at micron.com> writes:
>Hi all,
>This is a bit of a dumb question, but bear with me!
>Ok, I'm trying to compile NAS 1.6c under Solaris 8.
>I run xmkmf as per normal, and it runs fine. The problem is, it tries to
>use "cc" for everything. I've tried setenv CC gcc and the like, but it
>hasn't helped. I even linked (the not working) cc to gcc but it didn't
>help as it can't run with cc's options.
>Way back here: http://nas.codebrilliance.com/nas/nas-ml/msg00180.html
>Is a reference to the same problem. It doesn't really offer a solution,
>I've tried hacking a few files and it hasn't helped. Is there anyway to
>get xmkmf/imakefile to assume gcc instead of cc?
>Can anyone else help me?

Sounds like you have a solution. Back when I had Solaris I had
a perl script called 'cc' which took cc's options and converted them 
to gcc's options (or ignored them) and then called gcc.

More information about the Nas mailing list