[nas] cc/gcc issues with imake on Solaris 8

James Lee nas at canoemarathon.fsnet.co.uk
Thu Apr 15 02:29:51 MDT 2004

On 14/04/04, 13:37:37, <rhfreeman at micron.com> wrote regarding [nas] cc/gcc
issues with imake on Solaris 8:

> Ok, I'm trying to compile NAS 1.6c under Solaris 8.

> I run xmkmf as per normal, and it runs fine. The problem is, it tries to
> use "cc" for everything. I've tried setenv CC gcc and the like, but it
> hasn't helped. I even linked (the not working) cc to gcc but it didn't
> help as it can't run with cc's options.

Look in /usr/openwin/lib/config and read sun.cf. You might want to edit
the site.cf settings but I prefer to use defines at compile time.

The make commands I use are:

    imake -DHasGcc2 -DUseInstalled -I/usr/openwin/lib/X11/config
    make IMAKE_DEFINES='-DHasGcc2' \
    make CDEBUGFLAGS="-Os"

It needs a little work to get the "HasGcc2" passed around.
That will use any gcc, not just gcc2. I have gcc3.

I also patched the source to get dynamic libraries (maybe there is a
flag but I gave up and edited config/NetAudio.tmpl, #define SharedLibX
YES). Also clients/audio/util/checkmail is not going to work on Solaris
so I modified that to use $MAIL or /var/mail/$USER.


Save yourself the hassle and use a pre-compiled (with Sun cc Studio 8)
binary package:

It's waiting before full release, any feedback gladly received.

James Lee.

More information about the Nas mailing list