[nas] device or resource busy

Steve McIntyre steve at einval.com
Fri Aug 12 10:00:27 MDT 2011

On Fri, Aug 12, 2011 at 10:45:57AM -0500, hugo vanwoerkom wrote:
>I run a Debian Sid (=unstable) system with 2 sound applications: a Nas
>application to create custom sounds, and mplayer with sound only.
>I can run both applications simultaneously.
>Yesterday Sid upgraded nas, libaudio2, and libaudio-dev from 1.9.2-7 to 1.9.2-8.
>Since that upgrade I can only run 1 of my sound applications, if I run
>the 2nd one I get:
>[AO_ALSA] alsa-lib: pcm_dmix.c:1018:(snd_pcm_dmix_open) unable to open slave
>[AO_ALSA] Playback open error: Device or resource busy
>I was wondering if anyone could shed light on this problem. Is it a
>bug in the Debian version of the 3 Nas packages?

Hmmm. Might be. What happens if you downgrade back to 1.9.2-7? Also -
1.9.2-8 is the first nas upload I've made which installs into
multi-arch friendly locations, so that might be involved...

Steve McIntyre, Cambridge, UK.                                steve at einval.com
  Armed with "Valor": "Centurion" represents quality of Discipline,
  Honor, Integrity and Loyalty. Now you don't have to be a Caesar to
  concord the digital world while feeling safe and proud.

More information about the Nas mailing list