[nas] Strange nas problem...

Jon Trulson jon at radscan.com
Thu Oct 5 18:17:02 MDT 2000

On Tue, 3 Oct 2000, Erik Inge Bolsø wrote:

> Date: Tue, 3 Oct 2000 21:58:29 +0200 (CEST)
> From: Erik Inge Bolsø <knan at mo.himolde.no>
> To: nas at radscan.com
> Subject: [nas] Strange nas problem...
> There seems to be a problem with connections sometimes. If this happens
> to you for no apparent reason - auplay works fine, but an app run under my
> lib (libaudiooss) fails with the error below:
> ********
> eriki at spc107:~/mp3/Blind Guardian - Tokyo Tales$ mpg123 *
> High Performance MPEG 1.0/2.0/2.5 Audio Player for Layer 1, 2 and 3.
> Version 0.59r (1999/Jun/15). Written and copyrights by Michael Hipp.
> Uses code from various people. See 'README' for more!
> NAS connection to ?localhost:8000 broken (explicit kill or server
> shutdown).
> ********
> Try the following workaround: start playing a file with auplay. Then
> try your app again. When you hear that the other app gets its sound
> mixed in, kill auplay. It should work fine henceforth, as long as there
> are no multi-second pauses in output. Then you need to repeat the
> procedure.
> I've dug around in the NAS source, and tried adjusting the timeout I found
> in osdep.h. That didn't help...
> Could anyone explain the whys of this to me? Jon? Other gurus?

	I noticed that you've got 0.9.10 out - is this addressed
there?  It almost sounds like ssh is having a bit of a keep alive
problem.  I've never tried it that way myself.  Especially when you
mention it can also happen when the connection is established, but there
is a few seconds of silence.

	I'll have to try that...

	What options did you use with ssh/sshd?

Jon Trulson    mailto:jon at radscan.com
ID: 1A9A2B09, FP: C23F328A721264E7 B6188192EC733962
PGP keys at http://radscan.com/~jon/PGPKeys.txt
#include <std/disclaimer.h>
You talk like a Ferengi.

More information about the Nas mailing list